Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • anaconda (osx) 설치(아래 글을 참고)

  • 3.5버전 파이썬을 사용하여야 합니다. (zipline이 2.7, 3.5를 지원하므로 3.6이상 환경은 다시 가상환경을 만들어야 합니다.)

    Code Block
    languagebash
    $ conda create --name trading3.5 python=3.5
  • 가상환경(저의 경우 trading3.5로 지정)을 활성화(activate) 시키고 pip를 업그레이드 합니다. ( Window : conda activate trading3.5 )

    Code Block
    (trading3.5)$ python -m pip install --upgrade pip
  • 3주차에 저장한 라이브러리를 모두 설치해야 합니다. (특히, pandas관련) 지난주 정보를 참조하거나 다음 명령을 새로 만든 가상환경에서 실행하여야 합니다.

    Code Block
    (trading3.5)$ pip install DateTime  html5lib  lxml  numpy  pandas  plotly  requests  xlrd

    빠진 것은 그때 그때 설치하면 좋겠습니다.

  • pandas datareader 설치
    책에 있는 데로 하면 api가 호출이 안되네요. 그래서 최신 버전을 다음과 같이 설치해야 합니다.

    Code Block
    osx:
    (trading3.5)$ pip install git+https://github.com/pydata/pandas-datareader.git
    
    windows:
    (trading3.5)$ git clone https://github.com/pydata/pandas-datareader.git
    (trading3.5)$ python setup.py install
  • zipline 설치

    Code Block
    (trading3.5)$ conda install -c Quantopian zipline
  • jupyter  notebook 설치

    Code Block
    (trading3.4)$ pip install jupyter
    

...